Mac Pro 1,1 Restart on Wake issue FIXED

Until recently my 1st Gen Mac Pro suffered from the somewhat known ‘restart on wake’ issue, but no longer as a replacement PSU appears to have cured it.

I picked up the Mac Pro a couple years ago for £50 and I haven’t done much with other than install an SSD, upgrade to 32GB RAM and use it as a gitlab runner. It’s still running the original dual dual-core Xeon CPU’s and Yosemite which is really starting to show it’s age due to apps claiming the OS is too old for them to run after updating.. This combined with you effectively had to disable sleep to have a working machine led me to stop using it for a while.

I’d tried a few things over the months to isolate the restart on wake issue.

  • Installed a fresh copy of OS X Lion (The max officially supported version of OS X for the Mac Pro 1,1) – Issue still present
  • Swapped out the 32GB RAM from eBay with the original Apple 4GB RAM whilst still running Lion – Issue still present
  • Aquired a copy of Apple Service Diagnostics (3S108) to test hardware and run memory tests – No problems found, issue still present
  • Installed a copy of Ubuntu 14.04 for Mac and upgraded to 16.04 to isolate if the issue was specific to OS X – Issue still present

After trying all these things I’d ruled out that the issue wasn’t RAM or OS related, which seemed to be the cause of most problems for others running into a similar sounding issue. I figured it was either going to be something to do with the logic board or PSU and being as the PSU’s were going for £50 on eBay I thought I’d try my luck (also the fact it made some strange clicking noises when going into/out of sleep gave me a big hint).

After swapping out the PSU following this iFixit guide the issue immediately disappeared. Sleep now works perfectly again in both OS X and Ubuntu, however I’m sticking with Ubuntu 16.04 for the moment simply as that software is still supported.